Mechanic Advisor

Kia Repair Questions

gas tank issue 2004 Kia Optima

Car Model: 2004 Kia Optima
Location: Auburn, CA Submitted on April 20, 2015

charles
Auburn, CA

when we bought this car at 78K mi, there was no problem such as I'm about to describe.  About a year later, when we put gas in the tank, the car is difficult to start initially in that the engine acts as if it wants to cut out requiring the pumping of the accelerator to keep the car running. Thereafter, the car starts fine until the next purchase of gasoline.  We replaced the fuel pump and the gas cap with no improvement.

No one seems to know what the cause of this problem is.

Can you help?  Thanks very much.  Car now has 93,000 mi.

Rate this Question:

Answers

  • Photo
    Eugene
    Franklin, MA
    (0) Rated this answer helpful
    Have you tried replacing spark plugs
    Posted on March 07, 2016
    Respond

    Need more advice? Ask our experts.

    Other Kia Related Repair Questions
    • Stacy
      Canton, OH
      Starts correctly sometimes...
      My Sportage starts correctly sometimes but other times it hesitates to start. Like it won't catch and it keeps turning over. We had it into a local shop that i both know and trust but nothing came up ...
      2008 Kia Sportage | answers (0)
    • Frank
      Battery
      Battery voltage at 11.25 v when off
      2012 Kia Optima | answers (0)
    • Donald
      Clarksville, TN
      Coolant system
      While trying to start the engine, coolant shoots up from the radiator. The car will not start.
      2005 Kia Spectra EX | answers (0)
    • Oussama
      Not accelerating
      Not accelerating sometimes when driving it won't go up 20mph i have to stop and wait like 5 minutes before driving again
      2007 Kia Optima | answers (0)
    • Alexa
      Car pulling to left while driving?
      The tire pressure is fine in all 4 tires, what could be the cause of this?
      2011 Kia Soul | answers (0)
    • Regina
      Everett, WA
      Clutch repair
      How much cost clutch repair on Kia 2005 
      2005 Kia Spectra | answers (0)
    • Jessica
      Memphis, TN
      CAR WANT START
      I WENT TO START MY CAR AND IT WOULDN'T START. I STOPPED A COUPLE DAYS BEFORE I GOT A BOOST OFF AND IT WAS RUNNING FINE. AUTO ZONE SAID IT WAS MY BATTERY. I DIDN'T GET ANOTHER BATTERY. WHEN IT DIDN'T C...
      2008 Kia Spectra | answers (0)
    • Cat
      Carmichael, CA
      car won't start
      Car won't start even with jumper cables.
      2010 Kia Rio | answers (0)
    • Shane
      Columbus, NE
      charging system
      brand new battery and alternator charges at 14. 2 volts everything works fine no problems and then unexpectedly the car will die and the battery will be dead the next morning you can go out jump start...
      2001 Kia Sportage | answers (1)
    • me
      Brighton, CO
      over heating engin
      engine over heating,
       but inside air is cold even with the temperature set to full hot.  
      
      I have removed the thermostat but still have the same problem.  Coolent level is full.  I don't see any po...
      2007 Kia Sedona | answers (2)