Mechanic Advisor

Oldsmobile Repair Questions

hard starting 1996 Oldsmobile 88

Car Model: 1996 Oldsmobile 88
Location: Belleville, MI Submitted on October 23, 2014

sherry
Belleville, MI

When I start car in morning stalls have to give it gas...then when it runs it will idel high then drop to normal changed air flow sensor and still doing this

Rate this Question:

Answers

  • Photo
    Eugene
    Franklin, MA
    (0) Rated this answer helpful
    I would definitely look for a vacuum leak also look at the air intake tube and look for after the mass airflow sensor if there's a hole that would be called unmute it you're getting in there and would cause all kinds of issues also those cars are known to intake gasket leaks
    Posted on October 24, 2014
    Respond
    • Photo

      Shop Owner

      John - Allied Motorworks
      Sylvania, OH
      (0) Rated this answer helpful
      The problem you have described can be caused from either one or multiple issues. Have you had a tune-up with fuel filter? That would be the first place to start. Mass air flow sensor can cause the concern and if it was changed, did the installer perform a throttle body cleaning? Do you have a check engine light? If your lower intake gasket is leaking, you could have other issues that can cause this kind of concern. A vacuum leak could also be a part of the problem. This kind of problem would have to be diagnosed so you don't keep throwing parts at it. Even if your check engine light is not on, you can still have history codes read just to see if there are any "problems" that are contributing to the concern.
      Posted on October 23, 2014
      Respond

      Need more advice? Ask our experts.

      Other Oldsmobile Related Repair Questions